1. Want to see less ads, private areas and be able to post? Register Today to receive all these benefits and more!
Dismiss Notice

Want to see less ads, post content and the ability to buy & sell Oakleys?

Register Today or Login

  1. charlie4

    charlie4 Oakley Beginner

    Messages:
    76
    Trophy Points:
    83
    So I just purchased another Badman. Unboxed and opened frame and heard squeaks and creaks. My first two pairs are fine, but for some reason when I open this pair and put it on, the frame makes noises. Is it a manufacturers defect, is it something to be concerned about, should I take them back and get another pair. Anyone else have a Badman that squeaks ?
     
    Shade Station Oakley Sunglasses

    Register to Not see this ad
  2. SiRacer420

    SiRacer420 I've got a few Oakleys

    Messages:
    3,091
    Trophy Points:
    693
    I've seen another thread or two describing similar noises. Don't own one myself though.
     
  3. Bosoxyacht

    Bosoxyacht Oakley Expert

    Messages:
    460
    Trophy Points:
    533
    Try using lens cleaner on the orbitals and hinges. It usually silences squeaks.
     
    OakleyGuru379 likes this.
  4. motoGP_fanatic

    motoGP_fanatic Disciple of X-Metal

    Messages:
    1,043
    Trophy Points:
    693
    My Badman has no "noise", squeaks and creaks whatsoever..... Maybe a bit of cleaner as adviced by Bosoxyacht might help.
     
  5. charlie4

    charlie4 Oakley Beginner

    Messages:
    76
    Trophy Points:
    83
    Used the cleaner, and a lot of it. It worked for a bit, then after about a day the cleaner evaporated and it started again. Looks like they're going back and ordering a new pair. Thanks for the advice.
     
  6. Bosoxyacht

    Bosoxyacht Oakley Expert

    Messages:
    460
    Trophy Points:
    533
    the only other thing I would do isake sure all the bolts are tight, but if they are new, you may as well just exchange them.