1. Want to see less ads, private areas and be able to post? Register Today to receive all these benefits and more!
Dismiss Notice

Want to see less ads, post content and the ability to buy & sell Oakleys?

Register Today or Login

  1. thatoakleyguy

    thatoakleyguy Oakley Enthusiast

    Messages:
    608
    Trophy Points:
    183
    So I've finally got around to putting my double wide inside (moved from the garage) and am having lighting issues. When I plugged it up the bottom fluorescents would come on and stay on, while the LED's on top would come on and then immediately click off. I could click the switch on and off a few times but could never get them all lit up at the same time, either LED's were on or the fluorescents. Never both.

    Replaced all six of the LED's and they are a lot brighter and come on every time without issue. I went ahead and bought three 24" T8 17 watt lights to replace all of the ones currently in the tower.

    Long story short, I cannot even get them to flicker now. LED's are still working fine but I cannot get anything out of the new lights in the bottom or the top.

    Anyone have any experience/trouble with their ballasts in these? I searched and could not find anything similar to my issues.

    Thanks for any help, and of course I can get pics, but we all know what these look like.
     
    Shade Station Oakley Sunglasses

    Register to Not see this ad
  2. Brettc10

    Brettc10 Oakley Expert

    Messages:
    3,380
    Trophy Points:
    693
    I had to replace my Ballasts. All worked fine after that.
     
  3. SiRacer420

    SiRacer420 I've got a few Oakleys

    Messages:
    3,095
    Trophy Points:
    693
    My LEDs are doing the flicker but will stay on if I leave the switch on for about an hour then flip it off and on again. Guess it's time to replace them.
     
  4. IUSTEVE

    IUSTEVE Oakley Expert

    Messages:
    2,226
    Trophy Points:
    723
    Most the original ballasts in these cases were trash! Junk them and get new. I ripped all mine out as they stopped working within days of getting my tower
     
  5. thatoakleyguy

    thatoakleyguy Oakley Enthusiast

    Messages:
    608
    Trophy Points:
    183
    Ordered two new ballasts from amazon prime for about $10 each. WIll update when they get in
     
  6. i am rich

    i am rich The Silly Collector!

    Messages:
    3,184
    Trophy Points:
    673
    Got the link?
     
  7. thatoakleyguy

    thatoakleyguy Oakley Enthusiast

    Messages:
    608
    Trophy Points:
    183
    i am rich likes this.
  8. thatoakleyguy

    thatoakleyguy Oakley Enthusiast

    Messages:
    608
    Trophy Points:
    183
    After significant delay due to the recent weather, the second ballast is finally in. I'm gonna throw up a thread with a bunch of pics for anyone that wants to see what I did as soon as I finish.