1. Want to see less ads, private areas and be able to post? Register Today to receive all these benefits and more!
Dismiss Notice

Want to see less ads, post content and the ability to buy & sell Oakleys?

Register Today or Login

  1. Ramslacrosse09

    Ramslacrosse09 Oakley Enthusiast Premium Member Lifetime Member

    Messages:
    451
    Trophy Points:
    203
    I bought a black single wide 3.0 tower recently. I got the case as a steal of a deal but of course now the lights are not working. I am not very electrically inclined so I thought I would hit up the forum for their expert opinions.

    The Issue is every time I plug in the case in and flip the switch at the bottoms it buzzes for a second and than blows the circuit breaker. I thought maybe it was to much on that breaker so i ran a heavy duty extension cord and tried 3 other outlets in my house all with out luck, it blew every time. I took off all the covers and could not see any dark colored or burnt wires. I was wondering if the ballast went bad but I didn't think that should blow the breaker but not really sure.

    Any help would be greatly appreciated

    Also i can take pics tonight if someone needs a specific picture to help me figure it out
     
    Shade Station Oakley Sunglasses

    Register to Not see this ad
  2. the_owl

    the_owl Oakley Expert

    Messages:
    2,835
    Trophy Points:
    673
    I would grab a similar ballast off ebay for $20 or so. Also, theres two fluro bulbs under the bottom shelf and two in the top.
    the ballasts are cheap chinese crap.
     
  3. bigaub666

    bigaub666 Oakley Beginner

    Messages:
    23
    Trophy Points:
    53
    The lights are probably low voltage and the transformer is probably faulty ( dead short) causing the breaker to trip
    Replace the transformer with an equivalent type and you should be ok. The lamps may also have blown so will need replacing too
    I'm a uk electrician with 32 years experience.
     
  4. bigaub666

    bigaub666 Oakley Beginner

    Messages:
    23
    Trophy Points:
    53
    If fluorescent then a ballast as the owl said will need to be replaced , the lamps will probably be ok
     
  5. FEATUS

    FEATUS Oakley Enthusiast

    Messages:
    70
    Trophy Points:
    103
    I would suggest just replace the whole lighting assembly. Ballast type is kind a old school. Use the LED light instead.
     
  6. the_owl

    the_owl Oakley Expert

    Messages:
    2,835
    Trophy Points:
    673
    ballast.. I meant transformer for the DC part. mine was bad on my case when I got it.
    ebay
     
  7. bigaub666

    bigaub666 Oakley Beginner

    Messages:
    23
    Trophy Points:
    53
    I agree. Led is the future
    I have a led light in my single wide with no heat issues
     
  8. FEATUS

    FEATUS Oakley Enthusiast

    Messages:
    70
    Trophy Points:
    103
    In additional in LED it will last longer than normal floro light. Quite expensive but worth it.
     
  9. the_owl

    the_owl Oakley Expert

    Messages:
    2,835
    Trophy Points:
    673
    The spot lights on top have an Oakley OE LED replacement part. they will work on the existing transformer. Replacing the 20 inch fluro tubes with LEDS would be quite the project. the fluro bulbs are hard to find as is.