1. Please take 30 seconds to register your free account to see less ads, post topics, browse Oakleys, make friends and more!
    Register Now

Want to see less ads, post content and the ability to buy & sell Oakleys?

Register Today or Login

Discussion in 'Oakley Sunglasses Discussion' started by Herbsley, 10/3/11.

  1. Herbsley


    OK. So my O-ROKR Pro doesn't boot up any more. Worked the previous day from full charge, used for about 1 hour, and then won't boot the next day. Great. Usually get at least a few hours out of a charge.

    Holding down the Call button, and . . . . nothing.

    Plugged it in to charge again, just in case (even though it shows green light for full charge still). But to no avail.

    So, does anyone know of a way to soft-reset the O-ROKR Pro?
    Alternatively, does anyone know where/who will service one.

    I've been in touch with Oakley UK Customer Services obviously, who to be fair were as helpful as can be, and offered me a deal on a new one, which is fine. But what I didn't know was that, unlike the Thump range where Oakley can service them and swap out the electronics etc, they say that they DO NOT service O-ROKR units at all, as the internals were all Motorola so they just swap the whole sunglass for the customer instead of getting in there and fixing/swapping-out electronic parts.

    I'm sending an email to Motorola too - but am totally not holding my breath on that one.

    So here's a question to really test the Forum . . . . if I wanted to breathe life back into my existing O-ROKR Pro, anyone got any ideas? Anyone else had this problem? Just seems a shame to bin some glasses if they can be repaired or reset somehow.
    I've never had to throw away any Oaks before - and I don't really want to start now.
    Not on my watch.


    Shade Station Oakley Sunglasses

    Register to Not see this ad
  2. SpliceD


    Even if the worst case scenario happens, i wouldn't toss them. Just keep them around. They'll still work as sunnies. And maybe somewhere down the line, someone will be looking for parts, so you could still make a couple bucks.

    I threw away my OG frogs way back when. Wish i kept them to use for parts. The earstems and lenses were fine.

  3. Herbsley


    I'm just one of those types who wants to get stuff fixed.
    Yeah I could sell the lenses on Ebay or whatever, but I can't see the point in wearing them as sunnies when I've got way nicer ones that will be further up the rota.
    They are certainly not a pretty pair of Oaks. It was a definite "function over form" meeting they had at Oakley that day.

  4. Batwolf

    Batwolf Premium Member

    Is the battery done or will they just not boot up?

  5. RetinaBurn


    I'm not sure it will work for the O ROKR Pro, but I did have my Thump Pro lock up once and I did this:

    Most problems can be solved by resetting THUMP Pro. Simply hold down the Play / Pause button and the
    Previous Song / Rewind button at the same time.
    • Resetting will not erase the songs or files stored in memory.
    • If the reset procedure does not work, you may need to restore the internal software.

    Hope it helps!

  6. Batwolf

    Batwolf Premium Member

    If it's the battery, I know it's located on the left stem (as if you were wearing the glasses). It's a fairly common battery used in older cell phones and GPS units, if you get it removed you should be able to get a battery shop to order you one.

  7. Herbsley


    It's odd, cos I've just plugged it in to USB again to see what will happen, and it is still reading full charge (green light).
    But still absolutely nothing happening with any combination of button presses.

    (And good effort RetinaBurn, but that did not work. AAAAND, the O-ROKR did not come with software - it is just a Bluetooth headset really of course - so can't really restore/update anything).

    I think Batwolf may be on the right track here. The battery can't have held its complete charge since I last used it. So it's either the battery is faulty, or some electronics are faulty in thinking that the battery is OK! haha)

  8. RetinaBurn


    Ok, sorry that one didn't work, how about this one, it's for an O Rokr (not the Pro).

    You can reset the O-Rokr by turning the power off, and then back on.

    Locate the start button on the O-Rokr's left frame. It is between the volume "Up" and "Down" buttons.

    Press and hold the "Start/Call" button for approximately 3 to 5 seconds. You'll see the display light turn from green, to amber and finally to red. This turns the power off.

    Press and hold the "Start/Call" button for 3 to 5 seconds again. This turns the Oakley O-Rokr back on. The display light should turn from red, to amber and finally to green.

    After that I would probably have to agree it probably is the battery. Cross your fingers!

  9. Herbsley


    Unfortunately this is the process for switching off and booting back up.
    Usually used if the unit hasn't connected to your phone first time round.
    Nothing is happening.

    I can't believe O released this with no way of servicing, resetting, or even trouble-shooting instructions.

  10. ssnaider


    Hi, I had same problem and I solved after connecting to a computer with usb cable

    Hi, I was having the same problem for sometime. Full battery charged and no turn on when pushing the "phone" button...

    I followed the reset procedure above and nothing happen. Then I did the reset again while connected to my computer with an USB cable. Believe me or not, after disconnecting it on 1 minute or so, I tried to push the turn on button again and it started to work! The light started to appear. If you are able again like me to do it work, remember how to pair it. You need to have solid red color (7 seconds pushing until get it) and input code "0000" on your device to connect.

    Hope it works to you too, I mean, if you are still trying.

    To be honest, I also put my glass in front of my air conditioning in warm mode for some minutes before trying to connect to my computer, just in case there was some humidity inside, but I'm not sure it helped or not, as it only turn on after disconnecting form the computer usb.


Share This Page