1. Want to see less ads, private areas and be able to post? Register Today to receive all these benefits and more!
Dismiss Notice

Want to see less ads, post content and the ability to buy & sell Oakleys?

Register Today or Login

  1. Legacy0811

    Legacy0811 Oakley Enthusiast

    Messages:
    88
    Trophy Points:
    103
    So as you guys know I recently picked up a display case for cheap. All the lights worked expect for the one on the top that lights the Oakley up. Today I tried to fix it, and to see if it was the bulb I took one of the working ones from the bottom and put it on the top, it still didn't work. So assuming it's something electrical I put the bulb back in the bottom and now neither one of the bottom bulbs will light up. All my LED's work except for the one that didn't work when I got it. Is there an electrical problem somewhere or am I just dumb haha and what could it possibly be? Need Help! Lighting Issues! - ImageUploadedByTapatalk1407525265.830066.jpg Need Help! Lighting Issues! - ImageUploadedByTapatalk1407525276.963296.jpg Need Help! Lighting Issues! - ImageUploadedByTapatalk1407525287.680133.jpg Need Help! Lighting Issues! - ImageUploadedByTapatalk1407525297.947026.jpg Need Help! Lighting Issues! - ImageUploadedByTapatalk1407525308.213269.jpg Need Help! Lighting Issues! - ImageUploadedByTapatalk1407525317.779746.jpg

    I took the best photos I could, if anyone needs more just ask. Can anyone help me out?
     
    Shade Station Oakley Sunglasses

    Register to Not see this ad
  2. 77RRad

    77RRad Oakley Enthusiast

    Messages:
    235
    Trophy Points:
    183
    If you still need help PM me.
     
  3. OakleyCan

    OakleyCan Oakley Collector

    Messages:
    1,132
    Trophy Points:
    323